[phenixbb] on rosetta installation for phenix use

Smith Lee smith_lee123 at yahoo.com
Sun Feb 28 02:04:34 PST 2021

Dear All,

I have tried to install Rosetta for phenix use based on the guide in  https://www.phenix-online.org/documentation/reference/rosetta_install.html.

After the "tar xzf..." command, I added the directory for the installed rosetta (something like "export PHENIX_ROSETTA_PATH=/your-path-to-rosetta-here/") to my .bashrc (and in fact I also have added into /bash_profile) and sourced it.

For the final step to build the interface for rosetta_refine, as for my gcc version is 8.3.1, I have deleted the original site.settings in the directory ${PHENIX_ROSETTA_PATH}/main/source/tools/build/, and exactly copied the content in https://www.phenix-online.org/documentation/extras/site.settings and save it as site.settings in the directory ${PHENIX_ROSETTA_PATH}/main/source/tools/build/.

Command "nproc" displays 12, then I run "rosetta.build_phenix_interface nproc=12". In the running step for the above command, I remember it asked me "whether to install "sed" (I do not what is "sed" for), I answer "y" and "enter", it seems like the computer stopped. I opened another terminal, and all commands like "ls","cd" failed to work.

I restarted the computer, but I cannot log into my centos username account anymore.

I restarted the computer by initiating the centos secure start system, and deleted the export directory for the rosetta from the .bashrc and .bash_profile. In this way I restarted the computer and I can log into my centos user name account as usual. But as you know, my rosetta still did not work.

Thus, will you please advice what is wrong for my installation fof the rosetta (for phenix use) and how to make it workable?

I am looking forward to getting your reply.

Best wishes,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://phenix-online.org/pipermail/phenixbb/attachments/20210228/d19f145d/attachment.htm>

More information about the phenixbb mailing list